You (patient) are expected to have at least one of the following set of requirements to be able to attend a video call from your PCP:

Laptop
Component Requirement
Hardware Any modern machine with camera, microphone, and speakers, e.g.:
Mac/PC/Linux/Chromebook
Browsers
Operating System You’ll need to have the latest operating systems such as Windows 10 or MacOS Catalina. See details to obtain the latest versions of the browsers listed above.
Internet Internet connection with at least 2MBPS download and upload speeds. Check your network speed here.
Misc.
  • Javascript must be enabled (It is enabled by default, and we will give you a message that you need to enable it)
  • Make sure TCP ports 80 and 443 are open (sometimes firewalls block these ports, ask your IT team if you can’t connect with someone if this is causing it)
iOS/ Android Tablets
Component Requirement
Browsers
Internet Internet connection with at least 2MBPS download and upload speeds. Check your network speed here.
iPhone
Component Requirement
App 360 PatientTouch app for iOS
Internet Internet connection with at least 2MBPS download and upload speeds. Check your network speed here.
Android-based smartphone
Component Requirement
App 360 PatientTouch app for Android
Internet Internet connection with at least 2MBPS download and upload speeds. Check your network speed here.

INCOMPATIBILITIES:

  • 360 TeleWise is not compatible with Internet Explorer, Microsoft Edge and Firefox Browser. We are working hard to roll this out across most widely used browsers.
  • 36o TeleWise is not compatible with Amazon Kindle and other e-readers.
  • 36o TeleWise is not compatible/supported with voice controlled smart speakers like Alexa or Google Assistant.
Go Back to FAQs